Disappearing Menu

Post

Posted
Rating:
#4768 (In Topic #1033)
Avatar
Standard member
ironfeather is in the usergroup ‘Well-settled’

the main menu at the top is suddenly missing

Hello,

This is a weird problem that started with the last version and happens this version also.

I noticed thhat the main menu was missing, I clicked on the menu edit and did a SAVE and now its back…

this is my site (under construction)  http://futurecode.jp

I have done a few things to try and figure out why this happens. For the past few days I have not touched the site and the menu is OK but today I loaded the site (not logged in)  and it looks fine but on the 4th refresh suddenly the menu is gone again…..

I know if I login and SAVE the menu it will fix it but wanted to post first and see if anyone else has experienced this or has suggestions.

Thanks much

stevyn

UPDATE:  just did a refresh (not logged in) and now the menu is back…..  


 

Last edit: by ironfeather


———–
Publisher of IronFeather Journal since 1987.  Host of KGNU Colorado Radio for 20 years.
Currently in Japan & decided to focus on Composr as my number one CMS.
Compsr site in progress:  Nandalow
My Compsr edits : 
http://ironfeather.com/bbs/viewtopic.php?f=12&t=2862

 
Online now: No Back to the top

Post

Posted
Rating:
#4769
Avatar
Standard member
ironfeather is in the usergroup ‘Well-settled’
Looking at the VIEW SOURCE and I see that the gloabl CSS loads twice, is that normal?


its ok, one is CSS and the other is .js

 

———–
Publisher of IronFeather Journal since 1987.  Host of KGNU Colorado Radio for 20 years.
Currently in Japan & decided to focus on Composr as my number one CMS.
Compsr site in progress:  Nandalow
My Compsr edits : 
http://ironfeather.com/bbs/viewtopic.php?f=12&t=2862

 
Online now: No Back to the top

Post

Posted
Rating:
#4770
Avatar
Standard member
ironfeather is in the usergroup ‘Well-settled’
trying to replicate the error but no luck at the moment.  

when i do i will see what kind of info i can find and report back

 

———–
Publisher of IronFeather Journal since 1987.  Host of KGNU Colorado Radio for 20 years.
Currently in Japan & decided to focus on Composr as my number one CMS.
Compsr site in progress:  Nandalow
My Compsr edits : 
http://ironfeather.com/bbs/viewtopic.php?f=12&t=2862

 
Online now: No Back to the top

Post

Posted
Rating:
#4771
Avatar
Standard member
ironfeather is in the usergroup ‘Well-settled’
UPDATE:

ok now suddenly menu is missing

I have not logged in

many refreshes and menu still missing, tested in chrome and firefox

 

———–
Publisher of IronFeather Journal since 1987.  Host of KGNU Colorado Radio for 20 years.
Currently in Japan & decided to focus on Composr as my number one CMS.
Compsr site in progress:  Nandalow
My Compsr edits : 
http://ironfeather.com/bbs/viewtopic.php?f=12&t=2862

 
Online now: No Back to the top

Post

Posted
Rating:
#4772
Avatar
Standard member
Joey is in the usergroup ‘Honoured member’
When i look, i see your menu.
After some refreshes in different browsers i dont see any prolems.

Is it maybe in Chrome, and do you use some plugins for chrome?
Online now: No Back to the top

Post

Posted
Rating:
#4775
Joe
Avatar
Standard member
Joe is in the usergroup ‘Honoured member’
All I see is "FUTURE CODE" and "STEVEN". Is this all your menu contains?

If so, it seems to be showing fine on my end too.

Like Joey said, maybe some addons are messing with you? You can launch FF in a sort of "safe mode" (with addons disabled) by clicking Menu -> Help -> Restart with Add-ons Disabled…

Can you try a different computer?

I know it's annoying and I'm sorry it's not much help, but it is weird and will probably just take some troubleshooting and process of elimination to figure this one out.
Online now: No Back to the top

Post

Posted
Rating:
#4776
Avatar
Standard member
ironfeather is in the usergroup ‘Well-settled’
Hello,

Thanks much for testing. Yes, just two menu options, site is under construction so not much happening.

I just did many refreshes and no problems today.

Recently it has been very hot and my server has been reporting high temps for CPU chips so wondering if a slow server could have it time out and not load all the CSS as needed.

I think this is a problem that may be very hard to diagnose as its a rare happening and could be my browser/laptop or the small server it is hosted on. etc

I will report back if I can find any information or another instance of it happening.

My other Composr site on a different server is good and no problems.

 

———–
Publisher of IronFeather Journal since 1987.  Host of KGNU Colorado Radio for 20 years.
Currently in Japan & decided to focus on Composr as my number one CMS.
Compsr site in progress:  Nandalow
My Compsr edits : 
http://ironfeather.com/bbs/viewtopic.php?f=12&t=2862

 
Online now: No Back to the top

Post

Posted
Rating:
#4777
Avatar
Standard member
ironfeather is in the usergroup ‘Well-settled’
Hello,

Ok found a way to trigger it. If I edit an article and save it, menu is gone… (til I re-save menu and bring it back)

screen shot. the blue band is where my menu usually is…

screen.jpg

———–
Publisher of IronFeather Journal since 1987.  Host of KGNU Colorado Radio for 20 years.
Currently in Japan & decided to focus on Composr as my number one CMS.
Compsr site in progress:  Nandalow
My Compsr edits : 
http://ironfeather.com/bbs/viewtopic.php?f=12&t=2862

 
Online now: No Back to the top

Post

Posted
Rating:
#4778
Avatar
Standard member
ironfeather is in the usergroup ‘Well-settled’
I peeked at the view source and it appears normal, did an inspect and no errors on console.

Apache logs do show some 404 missing files such as:

HTTP/1.1/themes/Future_Code/templates_cached/EN/forms_ssl.css?1525504020626
HTTP/1.1/themes/Future_Code/templates_cached/EN/menu_popup_ssl.js?1525389105725
HTTP/1.1/themes/Future_Code/templates_cached/EN/calendar_ssl.css?1526757053

etc...

So I am curious about the number appended to the css URL,  what is that for and maybe this could be the cause?

so maybe the menu CSS is not loading  thus (404) 

 

———–
Publisher of IronFeather Journal since 1987.  Host of KGNU Colorado Radio for 20 years.
Currently in Japan & decided to focus on Composr as my number one CMS.
Compsr site in progress:  Nandalow
My Compsr edits : 
http://ironfeather.com/bbs/viewtopic.php?f=12&t=2862

 
Online now: No Back to the top

Post

Posted
Rating:
#4779
Avatar
Standard member
ironfeather is in the usergroup ‘Well-settled’
I logged out and now the menu has returned.
composr error log is empty

now i logged in and menu is missing.....

actually wonder if it could be my

"Restrict link visibility" setting which is : 

:start, _WILD:_WILD:steven, _WILD:_WILD:CV

The goal is to have the menu only shown at the landing page and if on steven page or CV page.


 

———–
Publisher of IronFeather Journal since 1987.  Host of KGNU Colorado Radio for 20 years.
Currently in Japan & decided to focus on Composr as my number one CMS.
Compsr site in progress:  Nandalow
My Compsr edits : 
http://ironfeather.com/bbs/viewtopic.php?f=12&t=2862

 
Online now: No Back to the top

Post

Posted
Rating:
#4780
Avatar
Standard member
ironfeather is in the usergroup ‘Well-settled’
Ok I did a test:

for the home (FUTURE CODE) menu link I removed the "Restrict link visibility"  settings so empty...

I edited the main start pages, saved and menu is OK

I then edited the steven page , saved and now the STEVEN link is missing...

I log out and the STEVEN link returns

----------------

I log in fresh and the steven link is missing

I change nothing but "save"  menu and now its back.....

I log out and its OK


----------------------------

Logged in and edited the CV (the drop down link under STEVEN)
saved that file and now the STEVEN link (and drop down CV) is missing...

Log out and it is OK

log in and steven link is missing
"save" menu and its OK
log out and its OK

so somehow when I edit a page and save it, it messes with the menu Restrict link visibility setting internally?

haha have to take a break, mind is confused....

 

———–
Publisher of IronFeather Journal since 1987.  Host of KGNU Colorado Radio for 20 years.
Currently in Japan & decided to focus on Composr as my number one CMS.
Compsr site in progress:  Nandalow
My Compsr edits : 
http://ironfeather.com/bbs/viewtopic.php?f=12&t=2862

 
Online now: No Back to the top

Post

Posted
Rating:
#4904
Avatar
Site director
Chris Graham is in the usergroup ‘Administrators’
Hi,

Sorry I took so long to reply on this topic, it's been a busy time for me, and this topic seemed too complex for me to handle quickly.

A few points…

1)

It's not that the menu is missing in the normal sense, as we don't get a Missing menu (some menu name). You may add it. error. It's just empty. I know that seems pedantic, but for debugging that's an important distinction.

2)

Apache logs do show some 404 missing files such as:
HTTP/1.1/themes/Future_Code/templates_cached/EN/forms_ssl.css?1525504020626
HTTP/1.1/themes/Future_Code/templates_cached/EN/menu_popup_ssl.js?1525389105725
HTTP/1.1/themes/Future_Code/templates_cached/EN/calendar_ssl.css?1526757053
So I am curious about the number appended to the css URL,  what is that for and maybe this could be the cause?

The numbers are the unix timestamp of the last modified time of the file. It's used as a 'cache breaker' - if the CSS or JS files are changed, the timestamp changes, so the URL changes, so browser caching will not apply anymore.

Anyway, sometimes these kinds of errors happen if the template cache was emptied while a user was loading a page. It's probably nothing to worry about.

3)

The issue is your match-keys. There's a very small note in the documentation about it:
If you use match-keys, you must disable caching on your menu block.

I realise this is easy to miss and unclear on what to do. We will elaborate on it:

The menus default broad menu block caching works against the idea of menus varying by individual URL.

If you use match-keys, you must either:
  • disable caching on your menu block with cache=0
  • disable JavaScript highlighting with javascript_highlighting=0 (which makes the cache bucket work on a page & screen level, which is good enough if your match-keys go no deeper).

For the default menu in the GLOBAL_HTML_WRAP.tpl template that may mean changing:

Code

{$BLOCK,block=menu,param={$CONFIG_OPTION,header_menu_call_string},type={$?,{$MOBILE},mobile,dropdown}}
to:

Code

{$BLOCK,block=menu,param={$CONFIG_OPTION,header_menu_call_string},type={$?,{$MOBILE},mobile,dropdown},cache=0}


Become a fan of Composr on Facebook or add me as a friend. Add me on on Twitter. Follow me on Minds (where I am most active). Support me on Patreon

Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about Composr whenever you see the opportunity or support me on Patreon.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying Composr on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Online now: No Back to the top
1 guest and 0 members have just viewed this.

Statistics

Users online:

Malatesa, deepu_ms, amit.nigam, Manu, 208 guests

Forum statistics:
  • 932 topics, 4,477 posts, 5,422 members
  • Our newest member is Sarawilliams7
Birthdays:
Back to Top