View Issue Details

IDProjectCategoryView StatusLast Update
0002578Composr[All Projects] Generalpublic2016-10-06 03:51
ReporterChris GrahamAssigned ToChris Graham 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0002578: Official non-maintained status
DescriptionParticular low-use/high-maintenance features will need to be sponsored.

Sponsorship involves taking direct responsibility including testing and bug fixing, or paying someone (such as ocProducts) to do that. In some cases it may also involve taking some down-stream responsibility, funding or maintaining frameworks or projects that Composr functionality is depending on.

Why?
1) Ongoing maintenance of a huge legacy of features is too burdensome
2) In particular some features may depend on third-parties, who may change things at any time
3) In particular some features may be particularly fragile, with a need to constantly bear them in mind for touching many different parts of the system, and regular re-testing, even when hardly anyone uses them
4) But we don't want to remove these features if they will continue to be very important for a small segment of people and need to be in the core of a CMS framework
5) We should not leave things decaying like other software does, conveying important and accurate information to our users is important
6) We want to guide people to a premium experience, i.e. let them know if their configuration isn't optimal
7) We want to give organisations the ability to fund things they are depending on, which seems fair

There will be an official codified mechanism for saying which affected features are currently sponsored and not. This mechanism will be used to automatically:
 - generate a central page on our website (this page will include text derived from this issue's text, and a codename-sorted table of features) [using a block]
 - add warning notes to feature-associated tutorials [using a Tempcode symbol]
 - add warnings when the functionality is installed (if relevant) [using a 'checks' hook, or using Tempcode symbols]
 - add warnings when the functionality is used [using a function call]
 - add warnings next to config options relating to functionality
 - automatically override addon categorisation to being 'Development' [a bit of ternary coding within the addon_registry file, where a function is called to get the status]
 - our release process should simplify down if stuff is not maintained, e.g. if no third party forum drivers are being sponsored, the "test on third party forum" release testing step should be removed
 - automatically add/remove stuff from our feature list [a bit of ternary coding where a function is called to get the status]

Warnings would always link back to the central page on our website.
Any of the existing "unsupported" or "(not) recommended" or "not fully supported" labelling would be replaced with this new system.

Data will be drawn from a .csv table in the project, with the following columns:
 - Feature codename
 - Feature title
 - Bug-fix sponsor (may be blank)
 - Current active sponsor (may be blank)
 - Notes
 - Non-bundled addon

Note that sponsoring functionality initially is not the same as sponsoring ongoing maintenance. Once something is implemented and delivered there isn't a guarantee it can be maintained forever without ongoing sponsorship.

No non-bundled addon will be put into the table *unless* it is being supported. The default assumption should be that no non-bundled addon is supported by the core developers. People wanting to support non-bundled addons can enquire and get them added to the list. Most will be supported by bug fixes, and automatically updated as Composr APIs change -- but not to the normal expected quality, and not proactively tested.

Bugs may be reported for unsupported functionality, and it may be fixed quickly as normal, or may be left on the tracker indefinitely -- depending on developer availability, ease of fixing the issue, and our sense of priority.

The release process should link to the new maintenance page, so the releaser is aware of all complexities that are being sponsored.
TagsRisk: Deprecates functionality
Attach Tags
Time estimation (hours)4
Sponsorship open

Relationships

related to 0002403 non-assigned Composr Track new software releases (ongoing) 
related to 0000651 non-assigned ocProducts non-bundled addons Sync with upstream 

Activities

Chris Graham

2016-07-14 12:12

administrator  

sponsored.xlsx (15,937 bytes)

Guest

2016-07-15 15:30

viewer   ~0004135

Last edited: 2016-07-15 15:30

View 2 revisions

the reported_content addon I think is technically sponsored by me since I'm rewriting it to be incorporated into support tickets instead of forum, include anonymous reporting, include meta_aware hook use, and replace cns_reported_posts (making it the one and only central reporting addon).

--Patrick

Chris Graham

2016-10-05 22:34

administrator   ~0004374

"the reported_content addon I think is technically sponsored by me"...

This isn't really about non-bundled addons per-se. Some show up in the list because they are particularly liable to break (so need special warnings) or are flag-ship, but the assumption is that any non-bundled addon could become unsupported unless explicitly given that flag-ship support.

It's more about ensuring the core product is predictable. Trying to guarantee addon stability is not ever really going to be expected I think.

Issue History

Date Modified Username Field Change
2016-05-08 17:49 Chris Graham New Issue
2016-05-08 17:50 Chris Graham Description Updated View Revisions
2016-05-08 17:59 Chris Graham Description Updated View Revisions
2016-05-08 18:06 Chris Graham Description Updated View Revisions
2016-05-08 18:09 Chris Graham Description Updated View Revisions
2016-05-08 18:10 Chris Graham Relationship added duplicate of 0000337
2016-05-08 18:52 Chris Graham Description Updated View Revisions
2016-05-08 19:02 Chris Graham Description Updated View Revisions
2016-05-08 19:03 Chris Graham Description Updated View Revisions
2016-05-08 19:13 Chris Graham Description Updated View Revisions
2016-05-08 19:14 Chris Graham Description Updated View Revisions
2016-05-08 19:14 Chris Graham Description Updated View Revisions
2016-05-08 19:17 Chris Graham Description Updated View Revisions
2016-05-08 19:35 Chris Graham Description Updated View Revisions
2016-05-08 20:14 Chris Graham Description Updated View Revisions
2016-05-08 20:23 Chris Graham Description Updated View Revisions
2016-05-08 21:39 Chris Graham Description Updated View Revisions
2016-05-08 21:39 Chris Graham Relationship added related to 0002403
2016-05-09 04:12 Chris Graham Description Updated View Revisions
2016-05-12 15:59 Chris Graham Description Updated View Revisions
2016-07-12 17:33 Chris Graham Description Updated View Revisions
2016-07-12 17:33 Chris Graham Additional Information Updated View Revisions
2016-07-12 17:33 Chris Graham File Added: sponsored.xlsx
2016-07-12 17:51 Chris Graham Description Updated View Revisions
2016-07-12 17:51 Chris Graham Relationship deleted 0000337
2016-07-12 17:51 Chris Graham Tag Attached: Risk: Deprecates functionality
2016-07-14 12:12 Chris Graham File Deleted: sponsored.xlsx
2016-07-14 12:12 Chris Graham File Added: sponsored.xlsx
2016-07-15 15:30 Guest Note Added: 0004135
2016-07-15 15:30 Patrick Schmalstig Note Edited: 0004135 View Revisions
2016-10-05 22:34 Chris Graham Note Added: 0004374
2016-10-05 23:25 Chris Graham Relationship added related to 0000651
2016-10-06 03:51 Chris Graham Status non-assigned => resolved
2016-10-06 03:51 Chris Graham Resolution open => fixed
2016-10-06 03:51 Chris Graham Assigned To => Chris Graham