View Issue Details

IDProjectCategoryView StatusLast Update
0003893Composrcore_form_interfacespublic2019-11-13 13:43
ReporterChris GrahamAssigned ToChris Graham 
Severitymajor 
Status resolvedResolutionfixed 
Product Version10.0.28 
Fixed in Version 
Summary0003893: URL fields failing to submit if containing relative URLs
DescriptionRelative URLs are not accepted in URL inputs, meaning many edit forms will not submit (Composr uses relative URLs to reference uploaded files).

This is a new issue prompted by a recent change where HTML5 validation was tied into Composr's own form validation, to ensure consistent validation.
TagsNo tags attached.
Attach Tags
Time estimation (hours)
Sponsorship open

Relationships

has duplicate 0003897 closedChris Graham Unable to Preview or Save in the Edit download screen 
has duplicate 0003949 closedChris Graham error al guardar 

Activities

admin

2019-10-03 21:03

administrator   ~0006103

Fixed in git commit 40a5fe534 (https://gitlab.com/composr-foundation/composr/commit/40a5fe534 - link will become active once code pushed to GitLab)

A hotfix (a TAR of files to upload) have been uploaded to this issue. These files are made to the latest intra-version state (i.e. may roll in earlier fixes too if made to the same files) - so only upload files newer than what you have already. Always take backups of files you are replacing or keep a copy of the manual installer for your version, and only apply fixes you need. These hotfixes are not necessarily reliable or well supported. Not sure how to extract TAR files to your Windows computer? Try 7-zip (http://www.7-zip.org/).

admin

2019-10-03 21:03

administrator  

hotfix-3893, 2019-10-03 9pm.tar (2,048 bytes)

Chris Graham

2019-10-07 16:19

administrator   ~0006109

Last edited: 2019-10-07 16:27

View 2 revisions

For some background - while this issue is 100% a Composr bug, it is related to this Mozilla documentation issue https://bugzilla.mozilla.org/show_bug.cgi?id=1586107

It was caused by a change made for the latest patch release https://gitlab.com/composr-foundation/composr/commit/836332315828954148a73d9a00f708e13d43ec68

Issue History

Date Modified Username Field Change
2019-10-07 16:19 Chris Graham Note Added: 0006109
2019-10-07 16:27 Chris Graham Note Edited: 0006109 View Revisions
2019-10-08 13:25 Chris Graham Relationship added has duplicate 0003897
2019-11-13 13:43 Chris Graham Relationship added has duplicate 0003949