View Issue Details

IDProjectCategoryView StatusLast Update
0001570Composr downloadable themes[All Projects] Generalpublic2017-04-08 17:05
ReporterChris GrahamAssigned To 
Severityfeature 
Status closedResolutionwon't fix 
Summary0001570: Bootstrap theme
DescriptionMake an Composr theme, such that Composr's templates bind into the CSS classes provided by Bootstrap.
Additional InformationThis will serve as a vector for developers to create attractive, and continuously modern, themes -- without having to design custom UI components themselves.

Hopefully bootstrap won't be badly forked before we get the benefit of this, as CSS and Javascript libraries suffer very badly from wheel-reinventing/fad-cycling every few years. However, it will be done within an actual client project, so is serving immediate demand.
TagsNo tags attached.
Attach Tags
Time estimation (hours)30
Sponsorship open

Relationships

duplicate of 0003206 closedSalman Composr Next generation theme (on hold) 
parent of 0001026 resolvedrutger1 Composr documentation Making a responsive design 

Activities

Chris Graham

2014-06-22 10:29

administrator   ~0002173

I think we will leave this, as the more I looked at Bootstrap, the more assumptions I saw it making that did not fit very well with things Composr wants to do.

Chris Graham

2014-09-02 11:16

administrator  

bootstrap.css (120,819 bytes)

Chris Graham

2014-09-02 11:17

administrator   ~0002252

Uploaded bootstrap.css from a product that was using Bootstrap - heavily modified due to issues we had with it.

Chris Graham

2015-12-07 23:51

administrator   ~0003233

Duplicated in 0002095

Issue History

Date Modified Username Field Change
2017-04-08 17:05 Chris Graham Relationship added duplicate of 0003206