View Issue Details

IDProjectCategoryView StatusLast Update
0001781Composrcorepublic2017-02-24 12:03
ReporterPatrick SchmalstigAssigned ToChris Graham 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0001781: Site-wide Bulletins / Announcements
DescriptionSome CMS systems allow for the ability to have site-wide bulletins and announcements displayed, eg for upcoming maintenance or very important bulletins for visitors.

Make a feature in Composr that would make this possible. The announcement would display in the notifications area of all pages, below the top logo and top menu.

Build this on top of the existing "closed site" options.

The closed site config option group gets additional config options in it...
 - Show message when open also, start date
 - Show message when open also, end date
 - Show message when open also, status level (inform, notice, or warn)
Additional InformationAttached is a screenshot of where the announcements might appear.

[Chris says...
I removed the idea of dismissing the alerts. Difficult to do well, to work for guests needs cookies, which increases HTTP communication overhead -- and people will inevitably dismiss it then forget what it said.]
TagsNo tags attached.
Attach Tags
Time estimation (hours)2.5
Sponsorship open


If users wish to sponsor this issue (optional, some issues are implemented without sponsorship)...
If users wish to sponsor this issue (optional, some issues are implemented without sponsorship)...

Activities

Patrick Schmalstig

2015-01-27 10:33

administrator  

Untitled.jpg (228,960 bytes)
Untitled.jpg (228,960 bytes)

Chris Graham

2015-01-27 11:24

administrator   ~0002491

I think we used to have this idea but concluded a simple template edit could serve as a workaround.

I suppose we could make an option for the closed site message to show even when the site is open, as a bulletin. That's a nice clean solution.

Rishi Saravanan

2015-01-30 18:32

reporter   ~0002500

I've also thought it would be nice to easily put a short important message at the top. Nice solution

Chris Graham

2015-02-09 22:32

administrator   ~0002550

Quoting feedback from user:
"On my site I plan on making a lot of announcements and unfortunately I haven't discovered a way to make a mass announcement on all the pages of the site so that people are aware of the announcement. My suggestion is to utilize the preview feature by adding a bar on the header of each page that can be color coded dependent upon the urgency of the announcement. Users can then hover over that bar to see a preview of the announcement. Once they've done that... the announcement bar can then be clicked off and it disappears until the next announcement is made."

Patrick Schmalstig

2015-02-09 22:56

administrator   ~0002551

Sounds like a good idea start, but if it's going to be a bar at the top, it may get in the way of the header image and the advertising banners. Hence that's why I suggested announcements go under the header, banner, and menu, but above the rest of the content. But the color coding is a nice idea and so is clicking them off.

sholzy

2017-01-03 23:24

reporter   ~0004667

I hacked together an announcement banner using the Activities addon back in late v8 but it broke in v9 and I never took the time to fix it. http://ocportal.com/forum/topicview/misc/developing/-hacked-hacking.htm?post_id=96338#post_96338

It was an invaluable site tool for bringing important info immediately to my members.

It would be nice to have an option to be able to show announcements to: members only, guests only, or both members and guests.

I'm looking forward to seeing this become reality, and because I find it invaluable (for me anyway) when I'm working again, I'll sponsor any remaining balance. (But, please don't wait for me because I don't know how long I'll be out of work.)

Chris Graham

2017-01-04 23:08

administrator   ~0004670

Thanks sholzy

Chris Graham

2017-01-25 23:23

administrator   ~0004716

Thanks for the sponsorship Jason! :)

Chris Graham

2017-01-27 13:26

administrator   ~0004720

Last edited: 2017-01-27 20:59

View 3 revisions

Now this is sponsored I've given it more thought and re-read over comments.

I don't think we should tie to the closed-site messaging like I originally suggested as that's a bit convoluted. In v10+ we can have as many config options as we want, no need to try and re-use them.
We'll have 5 new options:
 - site_message (message to show, mention it supports Comcode)
 - site_message_start_datetime (start date/time)
 - site_message_end_datetime (end date/time)
 - site_message_status_level (list: inform/notice/warn)
 - site_message_usergroup_select (a Selectcode string for filtering by usergroup, provide examples in the description for filtering by members only or by guests only)

We'll update the news tutorial to mention the new options and that you could put a link in the site message to a news article using Comcode, to elaborate on the message.

I want us to be able to support multiple messages, but doing a proper admin management module for it would be serious bloat.
So I'd like site_message to support JSON, which I'll document as an advanced thing in the News tutorial.
Example:
[code="JavaScript"]
{
    "messages": [
        {
            "site_message": "First message",
            "site_message_start_datetime": "2017-04-23T18:25:43.511Z",
            "site_message_end_datetime": "2017-04-24T18:25:43.511Z",
            "site_message_status_level": "inform",
            "site_message_usergroup_select": null
        },
        {
            "site_message": "Second message",
            "site_message_start_datetime": "2017-04-26T18:25:43.511Z",
            "site_message_end_datetime": "2017-04-27T18:25:43.511Z",
            "site_message_status_level": "inform",
            "site_message_usergroup_select": null
        }
    ]
}
[/code]

Chris Graham

2017-01-27 21:06

administrator   ~0004721

Implemented in https://github.com/ocproducts/composr/commit/654be88d6e024e3f6052d68eeff9dad620a238ec

KingBast

2017-01-27 22:49

administrator   ~0004722

"you'd add a news article then you'd like to it"

Chris Graham

2017-01-27 23:54

administrator   ~0004723

Thanks KingBast

Issue History

Date Modified Username Field Change
2016-12-08 01:23 Chris Graham Summary Feature: Site-wide Bulletins / Announcements => Site-wide Bulletins / Announcements
2017-01-03 23:24 sholzy Note Added: 0004667
2017-01-04 23:08 Chris Graham Note Added: 0004670
2017-01-24 19:06 Jason Verhagen Sponsorship Added Jason Verhagen: GBP &pound 82.50
2017-01-24 19:06 Jason Verhagen Sponsorship Total 0 => 82
2017-01-25 23:23 Chris Graham Note Added: 0004716
2017-01-27 13:26 Chris Graham Note Added: 0004720
2017-01-27 20:55 Chris Graham Note Edited: 0004720 View Revisions
2017-01-27 20:59 Chris Graham Note Edited: 0004720 View Revisions
2017-01-27 21:06 Chris Graham Note Added: 0004721
2017-01-27 21:06 Chris Graham Status non-assigned => resolved
2017-01-27 21:06 Chris Graham Resolution open => fixed
2017-01-27 21:06 Chris Graham Assigned To => Chris Graham
2017-01-27 22:49 KingBast Note Added: 0004722
2017-01-27 23:54 Chris Graham Note Added: 0004723