View Issue Details

IDProjectCategoryView StatusLast Update
0002635Composrcaptchapublic2017-11-19 23:35
ReporterChris GrahamAssigned ToChris Graham 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0002635: Support Google Re-Captcha
DescriptionGoogle Re-Captcha seems to be pretty smart, discussion of how it work here:
http://stackoverflow.com/questions/27286232/how-does-new-google-recaptcha-work

It may be some work to implement as it's a very different communication style to the self-hosted CAPTCHAs, but would be a small improvement.
TagsType: Spam
Attach Tags
Time estimation (hours)5
Sponsorship open

Activities

Chris Graham

2017-05-01 15:47

administrator   ~0005047

Now even better due to invisible "no CAPTCHA".

https://www.google.com/recaptcha/

Chris Graham

2017-08-30 14:25

administrator   ~0005187

This is now done for a client.

It became important because CAPTCHA on contact forms is often a bad idea (lost sales leads), yet you also don't want huge spam for those forms. In my clients case the forms are tied into SugarCRM so spam is totally unacceptable.

It will likely be integrated into v11, although it is a complex set of changes that will require more changes to be compatible with our v11 JavaScript rewrite.

Issue History

Date Modified Username Field Change
2016-06-02 20:01 Chris Graham New Issue
2016-06-08 00:06 Chris Graham Category core => captcha
2016-06-08 00:17 Chris Graham Tag Attached: Type: Spam
2017-05-01 15:47 Chris Graham Note Added: 0005047
2017-08-30 14:25 Chris Graham Note Added: 0005187
2017-11-19 23:35 Chris Graham Status non-assigned => resolved
2017-11-19 23:35 Chris Graham Resolution open => fixed
2017-11-19 23:35 Chris Graham Assigned To => Chris Graham