View Issue Details

IDProjectCategoryView StatusLast Update
0002677Composrcore_themeingpublic2017-04-08 17:05
ReporterPatrick SchmalstigAssigned ToChris Graham 
Severityfeature 
Status closedResolutionduplicate 
Product Version 
Fixed in Version 
Summary0002677: Consider flat theme for Composr
DescriptionMany competing Content Management Systems utilize either Bootstrap directly or their own form of a Bootstrap-looking theme. It is considered modern and practical to have a Bootstrap or otherwise flat and simple UI for apps and websites, especially given that we are moving in a progressively mobile society now.

Composr's default theme, unfortunately, falls short of this modern look. If the theme was altered (or a second separate default theme was provided) to look more flat and modern, I think Composr could get a boost in how it is perceived by CMS seekers. I know from experience a few people have remarked saying ocPortal 9 specifically looked like something from the 1990s and was outdated. Composr IMO does a better job at looking modern, but still does not keep up with the mainstream styles.

In order to make Composr look more modern, the ideal solution is to implement Bootstrap. However, that actually may not be a practical solution for Composr given how it was designed. Thus, our own version of Bootstrap styling may be better. Gradients are a thing of the past and should be removed in the flat theme, keeping solid colors and low-scale shading. Corners should not be rounded but instead pointed just like a square or rectangle. Ideally make use of Javascript animations for menus, buttons, and other control elements. Take care of differentiating between elements in styles (aka. a box versus a button). Use HTML5 wherever possible. Do not use links, especially in the mobile version, unless necessary (use buttons where possible). Get rid of ALL flash use, including in addons. Stick with colors that would stand out the most on a high-definition mobile device screen (We already do make those efforts in Composr). And so on and so forth.
TagsNo tags attached.
Attach Tags
Time estimation (hours)
Sponsorship open

Relationships

duplicate of 0003206 closedSalman Next generation theme (on hold) 

Activities

Guest

2016-06-27 20:33

viewer   ~0004070

I should probably note that although I really like Bootstrap myself, we should also put care into implementing it or a derivative of it. Bootstrap can really limit the ability to customize (aka. colors etc.). So it'll probably be good to try and find a balance... Composr has a modern UI that either uses Bootstrap or uses a derivative, and where users can still customize colors, images/backgrounds, etc.

Issue History

Date Modified Username Field Change
2016-06-27 16:28 Patrick Schmalstig New Issue
2016-06-27 19:54 Chris Graham Status non-assigned => closed
2016-06-27 19:54 Chris Graham Assigned To => Chris Graham
2016-06-27 19:54 Chris Graham Resolution open => duplicate
2016-06-27 19:55 Chris Graham Relationship added duplicate of 0002095
2016-06-27 20:33 Guest Note Added: 0004070
2016-07-22 16:29 Chris Graham Relationship deleted 0002095
2017-04-08 17:05 Chris Graham Relationship added duplicate of 0003206