View Issue Details

IDProjectCategoryView StatusLast Update
0003181Composrcore_themeingpublic2017-04-08 17:04
ReporterAdamAssigned ToChris Graham 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0003181: W3CSS Compatability
DescriptionThere are still certain elements missing from Composr which exist in external libraries. I know Bootstrap doesn't play well with Composr, but maybe W3CSS will.

https://www.w3schools.com/w3css/default.asp
TagsNo tags attached.
Attach Tags
Time estimation (hours)
Sponsorship open

Relationships

duplicate of 0003206 closedSalman Next generation theme (on hold) 

Activities

Chris Graham

2017-04-05 13:04

administrator   ~0004954

Thanks for drawing attention, but we already have a lot in motion for v11, and anyone may use any CSS frameworks they like as things currently are within their own themes.

There's a lot more to this than just adopting a particularly library that people like. These libraries tend to go out of fashion very quickly which would have a severe impact on us if we went too deep into a rabbit hole coding to the oddities of a specific library across a thousand templates, and we've learnt the hard way with a project that they can make the CSS so complex that nobody but a professional web designer can work with it. And even just upgrading to a new version of a library can be a massive overhaul, e.g. Bootstrap switched from LESS to SASS. We might do some kind of dual approach where we make some further improvements to the default theme (which will also have responsive design) and stay relatively simple, and then some very complicated official theme that has an advanced framework but is too complicated for regular users to be expected to change.

Issue History

Date Modified Username Field Change
2017-04-05 06:22 Adam New Issue
2017-04-05 13:04 Chris Graham Note Added: 0004954
2017-04-05 13:04 Chris Graham Status non-assigned => closed
2017-04-05 13:04 Chris Graham Assigned To => Chris Graham
2017-04-05 13:04 Chris Graham Resolution open => no change required
2017-04-08 17:04 Chris Graham Relationship added duplicate of 0003206