View Issue Details

IDProjectCategoryView StatusLast Update
0003965Composrcorepublic2019-11-24 21:10
ReporterChris GrahamAssigned ToChris Graham 
Severitytrivial 
Status resolvedResolutionfixed 
Product Version10.0.28 
Fixed in Version10.0.29 
Summary0003965: HTTPS URL proxier does not correct detect what HTTP URLs can be upgraded
DescriptionThe ensure_protocol_suitability function is used to map HTTP URLs to either an upgraded HTTPS URL, or the Composr URL proxy script. However, the HTTPS upgrade detection is not working.
TagsNo tags attached.
Attach Tags
Time estimation (hours)
Sponsorship open

Activities

admin

2019-11-24 21:10

administrator   ~0006169

Fixed in git commit 13e359c95 (https://gitlab.com/composr-foundation/composr/commit/13e359c95 - link will become active once code pushed to GitLab)

A hotfix (a TAR of files to upload) have been uploaded to this issue. These files are made to the latest intra-version state (i.e. may roll in earlier fixes too if made to the same files) - so only upload files newer than what you have already. Always take backups of files you are replacing or keep a copy of the manual installer for your version, and only apply fixes you need. These hotfixes are not necessarily reliable or well supported. Not sure how to extract TAR files to your Windows computer? Try 7-zip (http://www.7-zip.org/).

hotfix-3965, 2019-11-24 9pm.tar (60,928 bytes)

Issue History

Date Modified Username Field Change