View Issue Details

IDProjectCategoryView StatusLast Update
0003041Composrcataloguespublic2017-01-25 23:11
ReporterAdamAssigned ToChris Graham 
Severityfeature 
Status closedResolutionduplicate 
Product Version 
Fixed in Version 
Summary0003041: Custom Field Limitation
DescriptionCurrently if you add a custom field to something like a forum post, that field is available in all forums. Same with any you add for downloads. Surely this would be more useful if it could be limited to specific forums or download categories, as the idea of it being custom already implies it isn't standard. Or maybe I'm just missing something...
TagsNo tags attached.
Attach Tags
Time estimation (hours)
Sponsorship open

Relationships

duplicate of 0000394 non-assigned Per-category/per-catalogue custom category fields 

Activities

Adam

2017-01-25 08:30

administrator   ~0004702

Last edited: 2017-01-25 08:32

View 3 revisions

As a sidenote, I ended up on a screen where I could add entries outside of the actual content the field was created for, which I found confusing. Surely if it's added for use with a topic, I shouldn't be able to add entries outside of a topic. I did so anyway, and managed to browse the entry on the frontend of the site. It's not like that entry is available in a dropdown on new topics, so what use is it outside of a topic?

Chris Graham

2017-01-25 22:18

administrator   ~0004707

Do you know how you got to add a standalone entry in the catalogue? I cannot reproduce.

Chris Graham

2017-01-25 22:21

administrator   ~0004708

I think maybe you added a main_cc_embed pointing to that catalogue, then followed a link from there.

Chris Graham

2017-01-25 22:28

administrator   ~0004709

I've resolved the main_cc_embed issue, otherwise this is a duplicate.

The custom fields system is a generic subsystem that allows most content types to receive extra fields, but allowing individual categories to all have their own sets of fields is significantly more advanced.

Adam

2017-01-25 22:59

administrator   ~0004711

Last edited: 2017-01-25 23:09

View 3 revisions

It was all in the Admin Zone, I followed a do next link to view the custom field but cannot remember and cannot find where that field is now. If I can reproduce I will post the steps. I recall it was a forum topic field.

Just added a custom post field now, which is appearing on the new topic form underneath the custom topic field. Quirky, I assumed post fields would be on replies :)

Chris Graham

2017-01-25 23:03

administrator   ~0004712

Ok thanks. I clicked around a lot and couldn't find.

Adam

2017-01-25 23:11

administrator   ~0004713

Alright, well it deffo happened somehow and it was all in Admin Zone until I followed the link to see the custom field listed on the frontend in normal catalogue fashion, but it's no major issue.

Issue History

Date Modified Username Field Change
2017-01-25 08:24 Adam New Issue
2017-01-25 08:30 Adam Note Added: 0004702
2017-01-25 08:31 Adam Note Edited: 0004702 View Revisions
2017-01-25 08:32 Adam Note Edited: 0004702 View Revisions
2017-01-25 22:05 Chris Graham Relationship added duplicate of 0000394
2017-01-25 22:18 Chris Graham Note Added: 0004707
2017-01-25 22:21 Chris Graham Note Added: 0004708
2017-01-25 22:28 Chris Graham Note Added: 0004709
2017-01-25 22:28 Chris Graham Status non-assigned => closed
2017-01-25 22:28 Chris Graham Assigned To => Chris Graham
2017-01-25 22:28 Chris Graham Resolution open => duplicate
2017-01-25 22:59 Adam Note Added: 0004711
2017-01-25 23:01 Adam Note Edited: 0004711 View Revisions
2017-01-25 23:03 Chris Graham Note Added: 0004712
2017-01-25 23:09 Adam Note Edited: 0004711 View Revisions
2017-01-25 23:11 Adam Note Added: 0004713