View Issue Details

IDProjectCategoryView StatusLast Update
0000142Composrcorepublic2015-05-03 23:17
ReporterChris GrahamAssigned ToChris Graham 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000142: Merged sitemap API
DescriptionWe currently have a sitemap API, and a sitetree API, and the splurgh/tree-view code, and the content tree APIs. These are all structural content APIs and should be merged (we also have the content_meta_aware hooks, and also award hooks, but these are more service-orientated although they still can tie into structure).

Advantages:
    * simpler code
    * if the sitemap block uses this merged system we can remove the memory problems, by using the splurgh system for display.
    * we could get rid of the splurgh-powered 'tree' screens for content modules, which hardly get used, and instead make it so the main_sitemap block can be called up to show subtrees of the wider sitemap, as required (more flexible).
    * we can do a better job of menu auto-generation
    * we can get around some design problems with the splurgh system: bad caching model, performance problems due to showing too much at once, requirements for JS [we can now avoid splurgh entirely - see above]
Additional InformationAlso it would be nice if Comcode pages were rendered in a tree from this API, respecting their defined parenting structure (if one has been).
TagsRisk: Core rearchitecting, Risk: Major rearchitecting, Type: Cross-cutting feature
Attach Tags
Time estimation (hours)16
Sponsorship open


If users wish to sponsor this issue (optional, some issues are implemented without sponsorship)...
If users wish to sponsor this issue (optional, some issues are implemented without sponsorship)...

Relationships

parent of 0000140 non-assigned Category permissions for menus 
parent of 0000016 resolvedChris Graham Fully support menu stitching 
related to 0000130 non-assigned Foolproof content embedding 
related to 0001250 non-assigned Allow menu items to show current-page highlighting via analysis of breadcrumbs 
related to 0001366 resolvedChris Graham Adaptive menu mode 
related to 0001389 resolvedChris Graham XML Sitemap index 
related to 0001390 non-assigned Include "last comment date" in XML Sitemap date 
Not all the children of this issue are yet resolved or closed.

Activities

Chris Graham

2011-06-05 14:54

administrator   ~0000150

Also ID selection for the main_content block should work from the single site tree, when it's developed. So you don't select content-type+ID, you just browse to the content.

Chris Graham

2011-06-11 15:01

administrator   ~0000159

See if we can incorporate breadcrumbs into this, so they are auto-generated by the Site Tree where possible. Also tie in the logic about menu item subordination.

Chris Graham

2012-05-07 17:24

administrator   ~0000447

We don't need to see the term "entry point" anywhere in the UI or documentation. We can just use the term page-link.

BobS

2012-05-07 21:25

reporter   ~0000453

Suggest that tracker item 415 also be addressed at the same time.
http://compo.sr/tracker/view.php?id=415

Chris Graham

2013-04-10 21:12

administrator   ~0001353

This functionality may be built on top of the new Resource-FS.

Chris Graham

2013-04-11 00:28

administrator   ~0001355

Note that we want to make sure that Comcode page hierarchy comes out of this system correctly. Currently the pages come out flat, because they are top-level under a zone.

Chris Graham

2013-08-22 11:18

administrator   ~0001668

We can also likely merge in the do_next_menu hooks as part of the site-tree, (and give site-tree nodes support for icons in the process).

Chris Graham

2013-08-22 14:14

administrator   ~0001670

Also consider if we need to allow different XML sitemaps, per content-type (i.e. to stop the main one getting larger than is allowed, isolating size problems in a specific sitemap).

Chris Graham

2013-08-30 17:25

administrator   ~0001688

Absorb the bookmarks menu into the site-tree also.

Chris Graham

2013-09-07 13:50

administrator   ~0001694

Also features like list_galleries, which are of very limited use, can simply become part of the new site tree.

Issue History

Date Modified Username Field Change
2016-06-08 00:14 Chris Graham Tag Renamed Major rearchitecting => Risk: Major rearchitecting
2016-06-08 00:15 Chris Graham Tag Renamed Core rearchitecting => Risk: Core rearchitecting