Activity Feed grows regardless of settings

Post

Posted
Rating:
#7023 (In Topic #1898)
Avatar
Standard member
Terry is in the usergroup ‘Well-settled’
Okay last post for a while about small fixes. I actually hard coded a stop in the past, and tonight I'll do that again for this theme I'm playing with, but activity feed never stops expanding. Regardless of [ ] Grow or the timer setting. Setting the timer to 0 seems to be full blast expand, same as -1, but numbers greater than 0 are regarded as 2 seconds, it looks like. So when you scroll to the bottom of the feed, if it's a positive timeout number, the feed will continue to grow, and when you go to the bottom of that new feed set, it grows more. That's been going on since… many versions back, but it's easy to hard code a stop, but I thought I'd mention one more thing before my Monday (tomorrow).

Code

		{+START,IF_NON_EMPTY,{PAGINATION}}
			{+START,INCLUDE,AJAX_PAGINATION}
				ALLOW_INFINITE_SCROLL=0
				// ALLOW_INFINITE_SCROLL=0 was set to 1, but it never stopped scrolling, so it's 0 now to solve
				WRAPPER_ID={$GET,ajax_block_main_activities_wrapper}
			{+END}
		{+END}

Here's the hack I use to stop the grow. This is in MAIN_BLOCK_ACTIVITIES.tpl

Last edit: by Terry

Online now: No Back to the top

Post

Important!
Posted
Rating:
#7034
Avatar
Site director
admin is in the usergroup ‘Administrators’

Automated fix message

Terry said

Okay last post for a while about small fixes. I actually hard coded a stop in the past, and tonight I'll do that again for this theme I'm playing with, but activity feed never stops expanding. Regardless of [ ] Grow or the timer setting. Setting the timer to 0 seems to be full blast expand, same as -1, but numbers greater than 0 are regarded as 2 seconds, it looks like. So when you scroll to the bottom of the feed, if it's a positive timeout number, the feed will continue to grow, and when you go to the bottom of that new feed set, it grows more. That's been going on since… many versions back, but it's easy to hard code a stop, but I thought I'd mention one more thing before my Monday (tomorrow).

Code

		{+START,IF_NON_EMPTY,{PAGINATION}}
			{+START,INCLUDE,AJAX_PAGINATION}
				ALLOW_INFINITE_SCROLL=0
				// ALLOW_INFINITE_SCROLL=0 was set to 1, but it never stopped scrolling, so it's 0 now to solve
				WRAPPER_ID={$GET,ajax_block_main_activities_wrapper}
			{+END}
		{+END}

Here's the hack I use to stop the grow. This is in MAIN_BLOCK_ACTIVITIES.tpl
This issue has now been filed on the tracker as issue #4357, with a fix.
Important!
1 guest and 0 members have just viewed this.

Statistics

Users online:

amit.nigam, mytracker, deepu_ms, MVLipwig, Philip, Paul D

Forum statistics:
  • 1,342 topics, 5,887 posts, 7,206 members
  • Our newest member is homemaker
Birthdays:
Back to Top