video autoplay?

Post

Posted
Rating:
#6632 (In Topic #1719)
Avatar
Standard member
treedood is in the usergroup ‘Fan in action’
The tag below works while editing but does not when the page is saved and viewed.

Code

<video autoplay="true" src="uploads/filedump/videos/video1.mp4"> </video>
Is there a way to get this functioning?
Online now: No Back to the top

Post

Posted
Rating:
#6633
Avatar
Site director
Chris Graham is in the usergroup ‘Administrators’
Hi,

A few thoughts…

  1. Upon testing, I had no issues with the HTML integrity being maintained when using the editor, saving, and coming back. If there's an actual HTML integrity issue, it's likely a result of using a non-admin user with limited privileges, and the HTML being not in the allowed white-list.
  2. I see you have a relative URL in your code. That will work in WYSIWYG, as that has an HTML <base> element providing a base URL the same as Composr's base URL. But generally speaking, the web browser will have a base URL that is different on different pages. You should use an absolute URL (i.e. start http:// or https://) so that it works in any situation.
  3. Firefox was allowing playback in WYSIWYG for me but not on the site. There was a warning in the console about the site not being authorised to play. Chrome had no issue. So if you happen to be using Firefox (or other browsers with other settings to my Chrome test) it may simply be blocked due to a browser's "don't annoy the user" lock.


Become a fan of Composr on Facebook or add me as a friend. Add me on on Twitter. Follow me on Minds (where I am most active). Support me on Patreon

Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about Composr whenever you see the opportunity or support me on Patreon.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying Composr on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Online now: No Back to the top

Post

Posted
Rating:
#6636
Avatar
Standard member
treedood is in the usergroup ‘Fan in action’
Thanks….works fine now in chrome and ie but for firefox, I had to change the default browser options to get it to work.

Since most of the users on our site are "seniors", we decided against using the autoplay.

So much to learn here… :)
Online now: No Back to the top
1 guest and 0 members have just viewed this.

Statistics

Users online:

deepu_ms, Philip, ManojSree, mytracker, babu, Vaiva, amit.nigam

Forum statistics:
  • 1,361 topics, 5,909 posts, 7,289 members
  • Our newest member is PolicyGaga
Birthdays:
Back to Top